Back to overview
Downtime

Degraded performance

Oct 20 at 11:15am EDT
Affected services
Web Application

Resolved
Oct 20 at 04:06pm EDT

Systems are back online. Our health checks have not detected any issues for over a hour. We are marking this incident as resolved.

Updated
Oct 20 at 03:10pm EDT

Performance has substantially improved and the team is validating recovery.

Updated
Oct 20 at 01:43pm EDT

Availability continues to slowly improve, with successfully routed web traffic reaching ~90% of normal volume. Some customers may still be encountering issues connecting or degraded performance. The team continues to closely monitor the incident and validate recovery.

Updated
Oct 20 at 01:11pm EDT

Availability is improving. Customers may still encounter degraded performance or sporadic outages. The team continues to monitor the incident.

Updated
Oct 20 at 01:04pm EDT

A portion of web traffic is starting to resolve, but systems are still down for most customers. We continue to monitor the situation and attempt mitigating measures.

Updated
Oct 20 at 12:17pm EDT

Our team continues to monitor the situation and attempt mitigating measures. The incident is a result of a broad outage of the AWS us-east-1 region, specifically load balancing functionality which is preventing web traffic from reaching InvestNext servers. We will continue to post updates as we have them. The AWS team is also posting updates here: https://health.aws.amazon.com/health/status

Updated
Oct 20 at 11:51am EDT

We continue to monitor and diagnose the incident with our hosting provider. Our provider's load balancer is failing to route web traffic to InvestNext servers.

Created
Oct 20 at 11:15am EDT

Our web application is currently experiencing degraded performance coinciding with outages with our hosting provider.